Interface to the 'DeepL' Translation API

A wrapper for the 'DeepL' Pro API < https://www.deepl.com/docs-api>, a web service for translating texts between different languages. A DeepL API developer account is required to use the service (see < https://www.deepl.com/pro#developer).


News

deeplr 1.0.0

  • Improved documentation
  • New functions: detect, pimp

deeplr 0.3.1 (GitHub only)

  • New functions: detect2, pimp2
  • Small adjustments to the existing functions

deeplr 0.3.0 (GitHub only)

  • Integration of functions (translate2, toEnglish2 etc.) that call the DeepL API via JSON-RPC. No authentication key is required to use this service.

deeplr 0.2.0 (GitHub only)

  • Changed from GET to POST requests
  • Integration of the usage API call

deeplr 0.1.0

  • First version of the package.

Reference manual

It appears you don't have a PDF plugin for this browser. You can click here to download the reference manual.

install.packages("deeplr")

2.0.0 by David Zumbach, 5 months ago


https://www.deepl.com/translator


Report a bug at https://github.com/zumbov2/deeplr/issues


Browse source code at https://github.com/cran/deeplr


Authors: David Zumbach [aut, cre] , Paul C. Bauer [aut]


Documentation:   PDF Manual  


GPL (>= 2) license


Imports utf8, httr, tibble, purrr, tokenizers

Suggests dplyr


See at CRAN